Jason Coleman, creator of the popular Paid Memberships Pro plugin, published a post today, warning users that many payment gateways will soon require TLS 1.2. The encryption protocol secures communication between the server and customers’ browsers so that things like credit card numbers and addresses can be transferred safely. Coleman outlined the requirements that a server should support in order to be compatible with TLS 1.2: Run OpenSSL 1.0.1 or higher, or another cryptographic library that supports TLS 1.2 Run PHP version 5.5.19+ Run cURL version 7.34.0+ Since this is a fairly technical situation for the average e-commerce store owner or site admin to have to deal with, Coleman created a new plugin called TLS 1.2 Compatibility Test to help users determine if they need to upgrade. After activating the plugin, users can navigate to Tools > TLS 1.2 Compatibility to perform the test. The results will indicate if it’s necessary to upgrade the server’s version of OpenSSL, PHP, or the SSLVERSION of CURL. Users can take this information and relay it to their hosting companies when asking for an upgrade. The plugin offers testing via the PayPal and the How’s My
Share This