Not all plugins can work on PHP 5.2, like WordPress core currently does. Not all plugin developers want to support PHP 5.2, like core does. As a project, WordPress would like to move forward and encourage people to use more recent PHP versions. As one of the first steps to reach that goal, plugin authors can now specify a minimum required PHP version for their plugin in readme.txt file with a new Requires PHP header: === Plugin Name === Contributors: (this should be a list of wordpress.org userid's) Donate link: http://example.com/ Tags: comments, spam Requires at least: 4.6 Tested up to: 4.8 Requires PHP: 5.6 Stable tag: 4.3 License: GPLv2 or later License URI: https://www.gnu.org/licenses/gpl-2.0.html Users will see this displayed in the plugin directory, like this: As a next step, the WordPress core team is going look into showing users a notice that they cannot install a certain plugin or theme because their install does not meet the required criteria, with some user-oriented and host-specific instructions on how to switch their site to a newer PHP version. If you have any feedback on the subject, please leave a comment or join the next PHP meeting in #core-php channel on Slack.
Share This