Introducing the Minimum PHP Version chart. Historical chart displaying the minimum PHP version required to run each major WordPress version. Source The official requirements are available in the “Requirements” page on WordPress.org. In addition, the required PHP version is defined in the version.php file. History With the release of WordPress 2.0 in 2005, the minimum required version was set to PHP 4.2. In 2008, when WordPress 2.5 was released, PHP 4.2 got abandoned in favor of PHP 4.3. The last update was in 2011 when WordPress 3.2 abandoned PHP 4.x in favor of PHP 5.2. Insights WordPress has always tried to build flexible software that runs on common server configurations. But over the years, several PHP versions reached their official End-Of-Life. Therefore WordPress had to update the minimum required PHP version. Upgrading to newer PHP versions allows developers to use newer standards, efficient code, faster processing and many more obvious advantages. On the other hand, it requires hosting companies to invest money in software upgrades and new infrastructure. Not many companies do these upgrades. Anyway, from the data I learned that WordPress updated the minimum required
Share This